CRAN Package Check Results for Package uniswappeR

Last updated on 2022-09-27 07:50:58 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 0.6.0 16.45 135.67 152.12 OK
r-devel-linux-x86_64-debian-gcc 0.6.0 11.69 98.67 110.36 OK
r-devel-linux-x86_64-fedora-clang 0.6.0 194.65 OK
r-devel-linux-x86_64-fedora-gcc 0.6.0 190.52 OK
r-devel-windows-x86_64 0.6.0 73.00 195.00 268.00 OK
r-patched-linux-x86_64 0.6.0 12.98 122.71 135.69 OK
r-release-linux-x86_64 0.6.0 11.76 122.97 134.73 OK
r-release-macos-arm64 0.6.0 74.00 OK
r-release-macos-x86_64 0.6.0 96.00 OK
r-release-windows-x86_64 0.6.0 56.00 164.00 220.00 ERROR
r-oldrel-macos-arm64 0.6.0 65.00 OK
r-oldrel-macos-x86_64 0.6.0 97.00 OK
r-oldrel-windows-ix86+x86_64 0.6.0 32.00 17.00 49.00 ERROR

Check Details

Version: 0.6.0
Check: examples
Result: ERROR
    Running examples in 'uniswappeR-Ex.R' failed
    The error most likely occurred in:
    
    > ### Name: vis_pair_liq_positions_v2
    > ### Title: Visualise Liquidity Positions spread in a given pair
    > ### Aliases: vis_pair_liq_positions_v2
    >
    > ### ** Examples
    >
    > vis_pair_liq_positions_v2(pair_address = "0xf00e80f0de9aea0b33aa229a4014572777e422ee")
    Error in `fortify()`:
    ! `data` must be a data frame, or other object coercible by `fortify()`, not a numeric vector.
    Backtrace:
     ▆
     1. └─uniswappeR::vis_pair_liq_positions_v2(pair_address = "0xf00e80f0de9aea0b33aa229a4014572777e422ee")
     2. ├─ggplot2::ggplot(plot_data, aes(x = liquidityTokenBalance))
     3. └─ggplot2:::ggplot.default(plot_data, aes(x = liquidityTokenBalance))
     4. ├─ggplot2::fortify(data, ...)
     5. └─ggplot2:::fortify.default(data, ...)
     6. └─rlang::abort(msg)
    Execution halted
Flavor: r-release-windows-x86_64

Version: 0.6.0
Check: whether package can be installed
Result: ERROR
    Installation failed.
Flavor: r-oldrel-windows-ix86+x86_64